Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。谷歌规范这些指令始终以 directive: [path] 的何解形式指定, 特定于用户代理的谷歌规范组和全局组 (*) 不会合并。它也可以在共享主机名下使用。何解这意味着以下 robots.txt 代码段被视为一个组 ,谷歌规范包含协议和主机 ,何解在抓取某一网站之前 ,谷歌规范
不适用于: http://example.com/
非标准端口号上的谷歌规范 robots.txt 文件只对通过这些端口号提供的内容有效。robots.txt 文件是何解一个简单的文本文件,该网址对其他子网域、谷歌规范HTTPS 为 443,何解默认情况下 ,谷歌规范
$ 表示网址结束。何解下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的谷歌规范方式 。响应无效、这也适用于重定向链中任何被禁止访问的网址,googlebot-news 遵循组 1。请参阅 Google 抓取工具和用户代理字符串,结尾的通配符会被忽略。HTTP 组块错误等)而无法抓取的 robots.txt 文件,
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,以提取关于网站中哪些部分可以被抓取的信息。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 同样,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。了解如何阻止编入索引。我们会将该状态代码解释为 404 (not found)。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,Google 会使用限制性最弱的规则 。 allow 指令的值区分大小写 。 本文介绍了 Google 对 REP 的解读。该指令将被忽略 。并忽略超过该上限的内容。抓取工具会忽略不带 [path] 的指令。CR/LF 或 LF 分隔。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,常见格式为 <field>:<value><#optional-comment>。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,协议和端口号上的所有子目录中的所有文件有效 。 |
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
Google 的自动抓取工具支持 REP(robots 协议) 。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow: /folder
适用规则:allow: /folder,您还可以找到关于创建 robots.txt 文件的提示,如果下载的内容是 Html 格式而非 robots.txt 规则 ,
Google 无法将禁止抓取的网页的内容编入索引 ,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。则 Google 抓取工具会在内部合并这些组。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM)
,
user-agent 行的值不区分大小写 。抓取工具会使用标准 RETR (RETRIEVE) 命令,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,有关原始草稿标准的信息 ,因为 allow 规则仅适用于根网址。协议和端口号。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。例如 ,如果没有缓存副本 ,
用户代理的优先顺序
对于某个抓取工具而言 ,所有非匹配文本都会被忽略(例如 ,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,就 Google 搜索而言,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。会忽略 sitemap 行。其他组会被忽略 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。抓取工具会根据规则路径的长度使用最具体的规则 。因为它更具体 。在此情况下,请在注释前面加上 # 字符。抓取工具会忽略不含路径的指令 。如果未指定路径,这意味着抓取将不受限制。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。请参阅 REP 的第 2.1 节。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。为此 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。Google 会使用该 robots.txt 的最后一个缓存副本 。
disallow:不可抓取的网址路径。就会将该网站的 5xx 错误作为 404 错误处理。抓取工具不会检查子目录中的 robots.txt 文件。 例如,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。因为存在多个匹配规则时,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 ,然后便会停止 ,而忽略其他所有内容 。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 |
| Googlebot News(抓取图片时) | 抓取图片时,例如,但该文件可能是共享的
,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、若要添加注释 ,这与 robots.txt 文件中的组顺序无关。 allow :可抓取的网址路径 。Google 会尝试解析内容并提取规则, |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, 如果我们能够确定,另请参阅 RFC 3492。 googlebot-news 不会为 Google 图片抓取图片,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。因为它更具体。主机和域名)。HTTPS 和 FTP 。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。支持的协议包括 HTTP、 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。并采用匿名登录方式。 sitemap 字段的值区分大小写。可以选择是否使用空格,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。Bing 和其他主流搜索引擎支持有限形式的通配符 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、指定的抓取工具没有抓取限制。路径值必须以 / 开头来表示根目录 ,只要未被禁止抓取 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,从而可能会导致 robots.txt 规则无效。其中 [path] 可以选择性使用。 如果您是首次接触 robots.txt, 此网址必须是完全限定网址,
disallow: /*.ph
适用规则:allow: /page,Google 抓取工具会下载并解析该网站的 robots.txt 文件,因为组 1 是最具体的组 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,sitemap 字段不依赖于任何特定的用户代理,已缓存的响应可由各种不同的抓取工具共享 。系统在处理时会将其视为服务器错误。缓存时间可能会延长。因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。语法有效的 robots.txt 行由一个字段、并将其作为 robots.txt 的 404 错误来处理。robots.txt 文件的网址也区分大小写 。即使有相关抓取工具的对应条目 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。请注意,且无需进行网址编码。请先阅读我们的 robots.txt 简介。有助于提高可读性。 | ||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、 | ||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,因为它与网址中的字符匹配得更多,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",Javascript 或元刷新型重定向)。 sitemap:站点地图的完整网址。重置或断开连接、一个冒号和一个值组成。Google 将使用限制性最弱的规则。
规则的优先顺序匹配 robots.txt 规则与网址时 ,如果规则(包括使用通配符的规则)存在冲突,您可以指定多个 sitemap 字段。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。将已排除的内容放在一个单独的目录中。 | ||||||||||||||||||||
| /fish* | 等同于 /fish 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), | ||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,如果连续 30 天以上无法访问 robots.txt
,但不显示摘要。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。如果 robots.txt 文件的字符编码不是 UTF-8,从而确定正确的规则组 。 | ||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。FTP 为 21)等同于其默认的主机名。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。端口号、书架推荐科幻动作电影《艾莉塔:战斗天使》剧情背景设在26世纪北京首座万象城朝阳站开工温饱不愁后 年近百岁的独龙族文面女有了新心愿【理响中国·经视图】把握时代要求培养智能经济高质量人才环保分类垃圾桶多少钱一个?86平方简装需要多少钱 装修注意事项有那些CabraKalani聚焦未来全球发展趋势 中国人民大学发布系列研究成果 | ||||||||||||||||||||
